cover photo

elmussol

elmussol@elsmussols.org

php 7 vs php 5.6

 Xerta 
@Hubzilla Support Forum+ The machine I run this Hubzilla instance has this:

root@pendle:~# php -v                                                                                                                                                       
PHP 5.6.30-0+deb8u1 (cli) (built: Feb  8 2017 09:49:20)                                                                                                                    
Copyright (c) 1997-2016 The PHP Group                                                                                                                                      
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies                                                                                                              
    with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2016, by Zend Technologies


At the moment it also runs email, Nextcloud and Red Matrix (which will be taken down as soon as the Hubzilla instance is 100% ready for use).

I want to run php 7, it is an apt-get install away. What are the issues I need to think about in advance of this transition generally, and specifically with respect to Hubzilla and Red Matrix?
  
Running my node on PHP 7.2.4 with no problems so far.
  
Running my node on PHP 7.2, nginx and Postgresql 10 without critical issues.
  
i;m running on 7.2 as well. but he said he was using what's in his distribution. which is 7.0.
Nextcloud: nearly there

 Xerta last edited: Wed, 21 Mar 2018 00:08:35 +0100  
After wrestling with LetsEncrypt oddities I'm nearly there on the Nextcloud 13 install. On running the command-line install I get:

root@pendle:/var/www/nextcloud# sudo -u www-data php occ maintenance:install --database "mysql" --database-name "nextclouddb" --database-user "nextcloud" --database-pass "#############" --database-table-prefix "nc_" --admin-user "pault" --admin-pass "#############"                                                                 
Nextcloud is not installed - only a limited number of commands are available                                                                                                
Error while trying to create admin user: Failed to connect to the database: An exception occured in driver: SQLSTATE[HY000] [1045] Access denied for user 'nextcloud'@'localhost' (using password: YES)


Where should I be looking?
  
root@pendle:/var/www/nextcloud# sudo -u www-data php occ maintenance:install --database "mysql" --database-name "nextclouddb" --database-user "nextcloud" --database-pass "########" --database-table-prefix "nc_" --admin-user "pault" --admin-pass "########" 
Nextcloud is not installed - only a limited number of commands are available
[b]Nextcloud was successfully installed[/b]


Thank you very much. I believe I owe you a pint @Michael :-)
  
elmussol tagged elmussol's post with ⋕nextcloud
  
elmussol tagged elmussol's post with ⋕mysql